[BUG] Asset Browser: same folder showing up twice

Comments

3 comments

  • Richard McLoughlin

    Try turning off "Create default folders in new project" in the the preferences, then close the IDE and reload the project.

    I had the same issue and was told that the option was recently changed to recreate the folders even if loading an existing project and not a just creating a new one as the option name implies.

    It's because you have a folder named "Sprites", and then that option recreates the default folders when you load it - including the default "Sprites" folder - and the Asset Browser goes wonky.

    IMO that option either needs to be renamed, or preferably only affect NEW projects when they are created.

    It doesn't make sense to recreate them every single time a project is loaded, and that setting isn't project specific either so it's not easy to manage the setting on a per-project basis and is just asking for trouble when people forget to turn it off, load a project and have their Asset Browser get messed up.

    0
    Comment actions Permalink
  • David Pittracher

    "Create default folders in new project" was already turned off. 

    I tried turning that on and then off again. That initially fixed it.
    After restarting the project, the IDE crashed on startup.

    After restarting it again, the IDE worked again, but both folders were there again. Also another empty "Sprites" folder had been created.

    0
    Comment actions Permalink
  • David Pittracher

    Now I managed to get rid of the second folder.

    The problem occurred because of the following (at least I guess that's the reason): 
    I work on this project on different machines: a MacBook and a Windows PC.

    On the MacBook "Create default folders in new project" was disabled, while on the PC it wasn't.

    0
    Comment actions Permalink

Please sign in to leave a comment.