Mac Beta 11 (was also 10) IDE feeling slow & laggy (big RAM footprint)

Comments

16 comments

  • Adrian Nelson

    I re-started the IDE, re-opened the same windows as I had before and now editing is smooth again, the RAM footprint has gone back down and is now currently 571Mb as per screenshot below. I will monitor this and see how it grows during the day while using but it does look as though it has a memory leak of some kind.

    0
    Comment actions Permalink
  • Adrian Nelson

    So memory usage is climbing again - nearly 1Gb now - all I've been doing is re-factoring some of my regression test code and re-running my tests. I did have the runtime crash a couple of times due to my re-factoring of rect variables changing from an array to a struct so I wonder if this related to a possible memory leak when the runtime crashes when testing using VM from IDE (note this was not debugging from IDE - just running normally from it).

     

    0
    Comment actions Permalink
  • Adrian Nelson

    Hmmm, I just did a commit and push to git and the memory usage jumped up 24Mb to 1002Mb - that is all I just did since posting the above screenshot.

    0
    Comment actions Permalink
  • Adrian Nelson

    Been re-factoring bits of code to use structs more and testing game code - memory usage is still slowly climbing, now up to 1.44Gb

    0
    Comment actions Permalink
  • YoYo QA Dept

    Hello

    Thank you for getting in touch. Were you seeing the same behaviour in earlier beta builds or is this new to the newest?  Can you provide your System Information Report https://help.yoyogames.com/hc/en-us/articles/115005125607-How-to-provide-a-DXDiag-or-System-Information-report

    Thank you


    0
    Comment actions Permalink
  • Adrian Nelson

    Here is the DropBox link to my Mac system report - hope it helps. BTW I haven't noticed this before and I am currently using IDE v23.1.1.168

    https://www.dropbox.com/s/39md1zkck2tm013/MacBook%20Pro.spx?dl=0

    0
    Comment actions Permalink
  • Adrian Nelson

    So this morning I checked the RAM amount being used by the IDE (I just slept my Mac overnight so the IDE has not been restarted) and the RAM footprint dropped from just over 2Gb down to 937Mb.

    So this looks like it may be an internal caching process of some kind as I have not restarted the IDE.

    0
    Comment actions Permalink
  • YoYo QA Dept

    This is most likely an OS level garbage collection issue. We see a fluctuation in memory usage as the IDE operates. Are there major performance degradations based on what you're doing at the time, or is it just memory management issues?

    0
    Comment actions Permalink
  • Adrian Nelson

    But I haven't being doing much, just editing a few source files and testing under YoYo Runner - but the memory usage jumps up a lot and then after a while the IDE and editing text becomes very slow and laggy and becomes hard to use so the best thing is to quit the IDE and re-start it.

    I have NOT seen this before with older betas or the stable 2.2 IDE - this appears to be something that just started with the latest IDE - I'm running v23.1.1.168

    0
    Comment actions Permalink
  • YoYo QA Dept

    Hi,

    Can you retest this in the BB11 build, please?

    Thank you

    0
    Comment actions Permalink
  • Adrian Nelson

    I swapped over to the new beta as soon as it was available over the weekend, have been using it exclusively and it is now starting to lag - its currently intermittent ly laggy but definitely getting worse as time goes on, and the memory usage is climbing and I don't know why.

    all I'm doing is editing code, testing it then doing more of the same. I've not been opening assets within the project as I'm just writing lots of code at the moment and using the debugger on and off to check what's going on when something is not quite working as expected. I test regularly so am running the game frequently.

    Memory is now 2.5Gb and climbing as in screenshot below - given the fact that I have an spiffy MacBook Pro - 8 core i9 with 64Gb RAM the IDE should not be feeling laggy, when my project first opens and I am working it is maybe taking up 300 to 400 Mb (will double check when I quit and restart once it gets too bad) and it just starts to eat up memory.

    0
    Comment actions Permalink
  • Adrian Nelson

    BTW The above screenshot showing 12.6% CPU is with me doing nothin in the IDE - I am using Safari to type these comments so I don't know what it is doing - unless it is related to my large external screen size?

    0
    Comment actions Permalink
  • Adrian Nelson

    Starting to lag more now - almost at the point where I'm going to restart the IDE, here is the latest task manager screenshot showing memory usage now 2.76Gb - I have been testing and debugging and not touched any assets other than script files.

    0
    Comment actions Permalink
  • Adrian Nelson

    RAM still going up, calling it a night - will quit IDE and start afresh tomorrow:

    0
    Comment actions Permalink
  • Adrian Nelson

    Just restarted, here is memory usage with no project open and its taking 293Mb:

    and here it is with my project open with all the windows open I was using as above when memory was 2.90Gb, it is now 'only' 456Mb - so how did it grow to nearly 3Gb?:

    0
    Comment actions Permalink
  • Adrian Nelson

    Just opened up my Mac and the RAM usage has increased by just over 100Mb overnight - and I've not used GameMaker, so some background process within GMS IDE is leaking memory:

    0
    Comment actions Permalink

Please sign in to leave a comment.