Opting Into The GameMaker Studio 2 Beta Channel

With the 2.2.1 update to GameMaker Studio 2, a new Beta Channel has been added to Preferences.

This channel is for people who want to get bug fixes or new features sooner and in exchange are willing to risk encountering bugs or issues associated with a version that has not completed testing. We also ask of these users that they do report these issues as soon as they see them, so that by the time the "Stable" release is made these issues have been fixed.

To stress that point: the beta channel version of GameMaker Studio 2 may contain bugs that could corrupt your projects. It may also introduce project structure changes which, whilst being completely safe and correct, block you from taking that project back into earlier GMS2 versions or sharing the project with others who are not using the beta version.

Accordingly, the Beta Channel opt-in will not be available for minors, Educational users who log in using seats, or anyone using the free Trial version. We would also caution users of shared computers from opting-in, as the setting is for the GMS2 install, not per-user.

It is also currently not available on Steam (we will review this for possible inclusion in a later release). For our Steam users, your YoYo Account is valid for the non-Steam version as well, so feel free to install and use that to take part in the beta. If you haven't done so already, please follow the steps in our Using Your YoYo Account With Steam guide to link your Steam account to your YoYo Account.

 

For these first few betas before 2.2.1 goes stable...

You will need to download the beta IDE installer from the relevant link below.

Windows http://gms.yoyogames.com/GameMakerStudio-Installer-2.2.1.368.exe

macOS http://gms.yoyogames.com/GameMakerStudio2-2.2.1.368.pkg

This will update your IDE, but not your runtime at this point. You now need to follow the instructions in "Opting-In" to get your beta runtime.

Please note that if you have not used GMS2 before and you use a beta installer to install for the first time (not something we would recommend new users do), the IDE will automatically download you the latest Stable runtime during the first installation and then you can opt-in to restart and download the beta one.

As above, if your account is not eligible for the beta system, whilst the installer will work for you, you will be unable to get the correct runtimes. So please don't use the installer if you're a Trial user, below the age of majority in your territory, or an educational user.

 

Opting-In

Please Note: If your account is eligible for the beta, but you cannot see the Beta Channel section mentioned below, please File > Log Out and log in again. This will refresh your license and enable the Preferences section to be shown.

To opt into the Beta Channel, you will need to open the GameMaker Studio 2 Preferences and go to the Beta Channel section:

BetaChannel_Prefs.png

Before you can opt into the beta channel you are be required to check the two options presented, confirming that you are aware of the risks and have backed-up your project or are already using source control. You should take a moment to revise the End User Licence Agreement - specifically Section 2 - as advised.

Once both boxes are checked you can click the Opt into the GameMaker Studio 2 Beta button, which will prompt you to restart GameMaker Studio 2.

When it restarts, you will receive updates from the Beta Channel feed - please ensure that GMS2 is connected to the internet before opting-in, as there is very likely to be an update waiting.

Once opted-in, your release notes links in the Help menu within GMS2 will automatically change to show you the Beta pages, but if you want this info at any time you can find this here:

http://gms.yoyogames.com/ReleaseNotes-Beta.html 

http://gms.yoyogames.com/release-notes-runtime-Beta.html 

 

Managing Your Runtimes

Note that the Beta Channel comprises of two feeds, just the same as the "stable" channel does: the IDE and the Runtime feeds. Opting into the beta will prompt you to install the Beta IDE and that in turn will also download and set active the matching beta runtime. However, you can change the runtime you are using at any time from the Runtime Preferences (and even swap between Beta and Master runtimes):

Prefs_RuntimeBeta.png

 

Submitting Your Issues

The process here is no different to how we ask for issues to be filed now. Please continue to submit your issues using the normal contact form inside the GMS2:

Ensure that you pick the correct version number on the form when submitting your issue, then include any logs or sample projects as requested.

Please assume that we will request your logs and a sample, if your issue is to do with building a project or an in-game issue, and include these when filing the issue - as we will want to get your issue fixed and a new release out asap.

Please also be aware we need a .yyz export of your sample project, not simply the .yyp project structure file on its own. Use File > Export (Windows) or GameMaker Studio 2 > Export (Mac) to generate this .yyz.

 

Opting-Out

You need to opt out and then (optionally) install a "Stable" release over the top of your GMS2 install to finalise the process.

Again, remember that your project might not be able to be opened in an older Stable version, so if you use a Beta you might need to wait until the next Stable release and then opt-out.

If have opted into the Beta Channel, the Preferences button mentioned above will now show the option Opt out of the GameMaker Studio 2 Beta. Clicking this button and then confirming that you want to restart GMS2 to opt-out will mean the Beta Channel will be ignored and GameMaker Studio 2 will only update when a stable build is released.

However, you will still be using your beta IDE install, as GMS2 does not force you back onto a different IDE. In order to change this, when you click to opt-out the Release Notes page will be opened automatically so you can download a stable build of GameMaker Studio 2 (click the Version header of the one you want to install - we'd of course recommend you choose the latest one):

BetaChannel_DownloadStable.png

Then, you can just install this version to revert to a Stable IDE also.

 

 

Have more questions? Submit a request

0 Comments

Article is closed for comments.