GMS2 Required SDKs

This article details the required versions of the various tools and SDKs that GameMaker Studio 2 uses.

We do not recommend using third-party tools ahead of what is listed below - Studio won't know how to support them properly and you may give yourself build errors or even IDE instability.

Be aware also that for everything below we only offer support for physical machines running a single OS natively - not VMs (including Parallels), Bootcamp, "Hackintosh" Macs, or emulators, etc.

 

The following sections refer to IDE v2.1.3.273 using Runtime v2.1.3.189

 

For the Windows IDE

  • See general system specifications at the bottom of the GMS2 info page
  • Visual Studio 2015 or 2017 is required when building Windows YYC or anything to do with UWP or consoles - see the target's own section below for specifics
  • (VS2015/VS2017 requires Win 7 with SP1 or above - it won't install without at least SP1)
  • A separate physical Mac is still required for targeting Mac and iOS - see the target's own section below for specifics
  • Spine 3.4.02 can be used outside of GMS to export compatible Spine sprites (3.5.xx is usually fine, 3.6.xx/3.7.xx can give issues especially when using new functionality).
  • Steamworks SDK 1.35a if you're doing Steam builds (please use ONLY this version)

 

For the Mac IDE

  • See general system specifications at the bottom of the GMS2 info page
  • Xcode 9 is required before you can test/create Mac and iOS packages.
  • An Apple Developer account is required before you can test/create Mac and iOS packages, as you will need Xcode to sign the application as per Apple's requirements
  • A separate physical Windows PC is still required for targeting Windows, UWP or consoles - see the target's own section below for specifics

 

 

For Building/Running Games

Windows (setup guide here)

  • Windows 7, 8, 8.1, or 10
  • XP is not supported at all
  • Vista will require manual download and install of DirectX 11 if you don't already have this (you need to communicate this to your Vista players also)

Mac (setup guide here)

  • For building projects you need Xcode 9 which requires at least macOS Sierra 10.12.  Xcode 8.3.3 is also supported, but anything older than 8.3 needs to be updated now.
  • For playing GM games, OS X 10.9 or later is required for App Store games and OS X 10.6 or later is required for non-App Store games
  • All games are 32bit AND 64bit in the one package as of 2.1.3.

Ubuntu (setup guide here)

  • Ubuntu 14.04 LTS 64bit is the only distro we support
  • 32bit can be used for building projects, but requires additional packages to be installed
  • Other distros can run the game packages we generate and may also be used when building projects inside GMS, but we do not offer support for this.
  • All games are 64bit as of 2.1.3.

Android (setup guide here)

  • Android SDK Tools 25.2.5
  • Android 7.1.1 (API 25) (SDK Platform, Google APIs)
  • Android NDK 14b (64bit)
  • JDK 8u131 (64bit)

Suggested Option Settings

  • Build Tools - 26
  • Support Library - "26.0.0-alpha1"
  • Target SDK - 26
  • Min SDK - 16
  • Compile SDK - 26

Note: It is currently not possible to use Java JDK 9.0.1 as Gradle doesn't support this currently so please do not use this version.

Note: Android NDK 16 is not currently supported - this will be supported as of 2.1.4. If you use Android Studio, ensure that you don't update to this version. If you have installed NDK 16 with a first install of Android Studio, then see https://developer.android.com/ndk/downloads/older_releases.html

Note: Using Build Tools 26 or higher will require you to set the minimum SDK version to at least 14

Note: Support libraries are not listed in SDK Manager or Android Studio anymore, so you can find them here: [Your Android SDK install folder]\extras\android\m2repository\com\android\support\support-v4 (use the version's folder name as the value you enter into Game Options > Android)

iOS (setup guide here)

  • Xcode 9.2 (which requires macOS Sierra 10.12) is currently the most recommended version. Xcode 8.3.3 is also supported, but anything older than 8.3 needs to be updated now.
  • iOS 10 or above is required for games (Xcode doesn't build for older iOS versions now)

Note: Apple has released iOS 11.2.1 which is currently not supported by Xcode 9.2 and therefore your builds will fail until Apple releases a new version of Xcode which supports this. As a workaround you need to downgrade your device to 11.2 or older.

Consoles

Please note: you will only have access to the following links if your YoYo Account is licensed as a registered console developer

Have more questions? Submit a request

0 Comments

Article is closed for comments.