Unable To Build .ipa files (typically CSSMERR_TP_NOT_TRUSTED)

If you update your copy of Xcode you also need to do a couple of steps before building will work again. You might have already noticed a range of .ipa build errors can be triggerred by this update, but also failing to build the runner is a clear sign.

NOTE: This is by no means an exhaustive list, it's just a few common ones we've had mistakenly reported as bugs. We'll add to this list in due course as more common errors occur.

Firstly, make sure your certificates and profiles are still okay. Any issues here will need to be fixed before you progress. If you're getting blue error icons, see this site: http://developer.apple.com/library/ios/#technotes/tn2250/_index.html#//apple_ref/doc/uid/DTS40009933-CH1-TNTAG19 If this matches the error message you get when building follow the steps given to fix the error.

Next, you will need to download the matching copy of the Xcode Command Line Tools. Find this on the Downloads tab of Preferences inside Xcode. Wait while it downloads and installs, then close Xcode and try building inside GM or asking the Application Over to build the Runner again.

If the above didn't fix it, the next step is to run "sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer" in a Terminal window. (please note some Xcode installations may require "sudo xcode-select -switch /Applications/Xcode.app" instead) This simply tells your OSX which Xcode to use. Updating can make it forget.

If you have further issues, please file a bug and include your project as a .gmz attached to the bug report. If your project is too large, host it somewhere and give us a link (you will need to be able to host it until we say we've got a copy).

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk