GM:S 1.4 Required SDKs

This article details the required versions of the various tools and SDKs that GameMaker: Studio uses. Please note that we do not recommend using third-party tools ahead of what is listed below - Studio won't know how to support them properly and you may give yourself build errors, etc.

The following sections refer to these releases:

  • Stable: 1.4.1804
  • Beta: 1.4.9999 (Recommended release)
  • Early Access: (Not supported - please uninstall and use one of the two above.)

 

GM: S 1.4 Requires a PC

GameMaker: Studio 1.4 only runs on Windows. A macOS version is not available, nor is a browser-based interface.

Windows Vista, 7, 8, 8.1, and 10 are all supported.

Windows XP is not supported, as you will not be able to download your modules, due to SSL security changes on various webservers globally in 2016. This is out of our control.

 

External Tools You Might Want

  • Spine 3.4.02 (Please use ONLY this version)
  • Steamworks SDK 1.35a (Please use ONLY this version)
  • SVN 1.7 or 1.8 (You are also able to use a batch file to route commands to tools of your choice)

 

Requirements For Building and Running Your Games

Android / Amazon Fire

Android SDK (scroll down to the command line tools only, not the Android Studio download)

  • Build Tools: 24+
  • APIs Required: 23+ (However add in whatever your extensions require too)
  • Support Library: 23.2.1+
  • Support Repository: 35+

Note: Support libraries are not listed in SDK Manager anymore, but you can find them here [your Android SDK install folder]\extras\android\m2repository\com\android\support\support-v4

Android NDK 16b (32/64 Bit depends on your OS)

  • 17c releases after support for 1.4 ended and so is not actively supported

Java JDK 1.8 "8u102" (32/64 Bit depends on your OS, but also you do need to be using a fairly recent Android SDK in order for it to support Java JDK 64bit)

 

macOS

OS X 10.9 or later is required for non-App Store games.
macOS 10.12 (Sierra) or later is required for App Store games.

macOS 10.14 (Mojave) releases after support for 1.4 has ended and so is not actively supported.

Requires Xcode to build any projects:

  • Xcode 8.3-9.2 - if using 1804
  • Xcode 9.3 - if using 9999
  • Xcode 10 releases after support for 1.4 ended and so is not actively supported

 

iOS

iOS 10.0 or later is required for games (this is all Xcode will build for).

Requires Xcode to build any projects:

  • Xcode 8.3-9.2 - if using 1804
  • Xcode 9.3 - if using 9999
  • Xcode 10 releases after support for 1.4 ended and so is not actively supported

 

Windows YYC

Requires Microsoft Visual Studio 2013 to build any projects.

 

Windows UWP

Requires Microsoft Visual Studio 2015 to build any projects. You will need to install Win 10 SDK versions 10.0.14393.0 AND the older 10.0.10240.0 (because Visual Studio 2015 requires 10.0.10240.0)

 

Consoles

Please note: you will only have access to the following links if your YoYo Account is licensed as a registered console developer

       
Have more questions? Submit a request

0 Comments

Article is closed for comments.