YoYo Games Ltd.

GameMaker QA Sep 15 Known Issues

With iOS 8 Apple changed the location your apps save/load their files to/from. As such, we have had to adjust to this new scheme. Our saving/loading now supports iOS 8 as well as iOS 7 and older, but you will need to rebuild and resubmit apps if you wish them to work on iOS 8.

As of 1.3.1409 and 1.4.1398 we introduced runner-only support for iOS 8.0. Applications were not included as we needed to wait for iOS 8 and Xcode 6 to become final before doing further testing. Now that they have gone "gold master" with iOS 8 and Xcode 6, a 1.3 and a 1.4 release which include support for applications are coming as soon as we have them tested.

You will need to update Xcode to be v6 in order to make applications.

Contrary to a couple of GMC discussions, there is no need to submit a ticket to request a version, and as soon as a release is ready it will go public and offer you an update as normal. The pre-release version being discussed on the GMC is not a final release and has issues, so please do not use or share that version.

 

 

Please be aware also that Apple have made GameCenter and Instruments require you to enable the use of them in developer mode - otherwise, Instruments will throw a build "error" when deploying your game to your iDevice (same as it often does in iOS 7 anyway) and GameCenter won't even attempt to connect.

For Instruments: Settings > Developer > Enable UI Automation must be ON.

For GameCenter: Settings > GameCenter > Sandbox must be ON.

 

Overview | Recent