Required SDKs

This article details the required versions of the various tools and SDKs that GameMaker Studio 2 uses. Please note that we do not recommend using third-party tools ahead of what is listed below - Studio won't know how to support them properly and you may give yourself build errors, etc.

Be aware also that for everything below we only offer support for physical machines running an OS natively, not VMs (including Bootcamp or Parallels) or emulators, etc.

The following sections refer to IDE 2.0.2.44 using runtime 2.0.1.27

 

For GMS2

  • See system specifications at the bottom of the GMS2 info page
  • Visual Studio 2015 is required when building Windows YYC packages
  • (VS2015 requires Win 7 with SP1 or above - it won't install without at least SP1)
  • Spine 3.4.0.2 is required for exporting compatible Spine sprites

 Be aware we do not support Visual Studio 2017 RCs (at all)

 

For Games

Windows (setup guide here)

  • Windows 7, 8, 8.1, or 10
  • XP is not supported at all
  • Vista will require manual download and install of DirectX 11

Mac (setup guide here)

  • OS X 10.6 or later is required for non-App Store games
  • OS X 10.9 or later is required for App Store games

Ubuntu (setup guide here)

  • 14.04 LTS 64bit is the only distro we support
  • Other distros can use the game packages we generate and may also be used when building, but we do not offer support for this.

 

 

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk